On May 6, 4:26  鮮 
> I used ruby-1.8.7-p249-i386-mingw32.7z on the windows 7 x64, and have
> installed the devkit. But it failed to build the native extension of
> eventmachine with error message as follow:
>
> H:\study\fybjy\myoa>gem install eventmachine
> Building native extensions.   宮
> ERROR:    > ERROR: Failed to build gem native extension.
>
> H:/ruby/bin/ruby.exe extconf.rb
> checking for rb_trap_immediate in ruby.h,rubysig.h... yes
> checking for rb_thread_blocking_region()... no
> checking for inotify_init() in sys/inotify.h... no
> checking for __NR_inotify_init in sys/syscall.h... no
> checking for writev() in sys/uio.h... no
> checking for rb_thread_check_ints()... no
> checking for rb_time_new()... yes
> checking for windows.h... yes
> checking for winsock.h... yes
> checking for main() in -lkernel32... yes
> checking for main() in -lrpcrt4... yes
> checking for main() in -lgdi32... yes
> checking for main() in -lssl... no
> creating Makefile
>
> make
> MAKE Version 5.2   㱹 > Fatal: 'ruby.h' does not exist - don't know how to make it
>

http://wiki.github.com/oneclick/rubyinstaller/troubleshooting

--
Luis Lavena