On Apr 14, 1:08    쮮
> Aa Wilson wrote:
>
> > As a further follow-up, this was the case for a great number of the
> > source files (possibly all--I didn't count, just did a find-replace).
> > Also, certain other rubygems source files have the first few characters
> > chopped off--for instance,
> > C:\scripting\ruby-1.9.1\lib\ruby\site_ruby\1.9.1\rubygems\package\tar_input .rb
> > has "- coding: iso-8859-1 -*-", which should (probably) actually be "#--
> > coding: iso-8859-1 -*-".
>
> One last-followup, with a workaround.
>
> A large number (the majority) of the files in the rubygems directory
> noted above were missing the first four characters. Since the files in
> ruby-1.9.1\lib\ruby\site_ruby\1.9.1\rubygems were copies of the files in
> rubygems-1.3.6\lib\rubygems\, copying the contents of the latter into
> the former resolved this issue.

The problem might be related to the version of Ruby 1.9.1 you're
using.

can you tell us which version of Ruby 1.9.1 are you using? (ruby -v)

Also, to the encoding of your Windows installation.

What is the language of your installation and your console encoding?
(chcp)

Chopping the first characters might be a UTF encoding issue.

RubyInstaller do not present this issue. Can you test downloading
1.9.1 of RC2 and manually install RubyGems 1.3.6 on top of it?

More details here:

http://rubyinstaller.org/

--
Luis Lavena