Hello

Which version of Ruby are you using?
You can check it by:

  ruby -v

If it is [i386-mingw32] or [i386-mswin32],
you can install a binary package by:

  gem install narray --platform=x86-mingw32

Otherwise, you need some compiler to compile sources.

Masahiro Tanaka


H- 16 wrote:
> I'm trying to DL a gem but I keep getting this message:
> 
> 
>>E:\Ruby\bin>cmd /k "F:\Torque Game Engine Demo\System\Hack\Ruby\bin\gem.bat"
>>The system cannot find the drive specified.
>>
>>E:\Ruby\bin>gem i narray
>>Building native extensions.  This could take a while...
>>ERROR:  Error installing narray:
>>        ERROR: Failed to build gem native extension.
>>
>>E:/Ruby/bin/ruby.exe extconf.rb
>>checking for sys/types.h... no
>>checking for u_int8_t... no
>>checking for int16_t... no
>>checking for int32_t... no
>>checking for u_int32_t... no
>>creating narray_config.h
>>creating Makefile
>>
>>nmake
>>'nmake' is not recognized as an internal or external command,
>>operable program or batch file.
>>
>>
>>Gem files will remain installed in E:/Ruby/lib/ruby/gems/1.8/gems/narray->0.5.9.7
>> for inspection.
>>Results logged to E:/Ruby/lib/ruby/gems/1.8/gems/narray->0.5.9.7/src/gem_make.out
>>
>>
>>E:\Ruby\bin>
> 
> Does anyone know how to solve this? Btw,
> 
>>E:\Ruby\bin>cmd /k "F:\Torque Game Engine Demo\System\Hack\Ruby\bin\gem.bat"
>>The system cannot find the drive specified.
> 
> This is not a problem.

-- 
Posted via http://www.ruby-forum.com/.