--mYCpIKhGyMATD0i+
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

THIS IS NOT A JOKE. I AM VERY SERIOUSLY RELEASING PHUBY.

Phuby embeds a PHP runtime inside a Ruby runtime.  This gem will let
rails scale by allowing you to run PHP applications inside your rails
applications.

To see it in action, check out these youtube videos:

  http://www.youtube.com/watch?v=lsWKjS6Vufw
  http://www.youtube.com/watch?v=MXERy8Y2eVo

I ENCOURAGE YOU TO NEVER EVER EVER INSTALL THIS SOFTWARE.  Not only is
it difficult to install, but your computer might implode from the sheer
awesomeness of being able to use PHP inside your ruby applications.

Just think how awesome an embedded PHP interpreter would be.  I know
most of you (like me) are coding Ruby day in and day out thinking "if
only I were programming in PHP, this would be much easier".  Well, (*if*
you're brave enough) now you can!

Anyway.  You can check out the codes here:

  http://github.com/tenderlove/phuby

Below is the README with installation instructions.  Remember that these
instructions are not for the faint of heart.  I forgot to add this to
the README, but the last step is sacrificing one chicken.

# phuby

* http://github.com/tenderlove/phuby

## DESCRIPTION:

Phuby wraps PHP in a loving embrace.  Exposes a PHP runtime in ruby

## FEATURES/PROBLEMS:

* many

## SYNOPSIS:

  rt = Phuby::Runtime.new
  rt.start

  rt.eval('$hello = "world"')
  assert_equal "world", rt['hello']

  rt.stop

## REQUIREMENTS:

* php

## BUILD INSTRUCTIONS:

* Download php-5.3.0

The following instructions apply to OS X (probably not needed on linux):

DO NOT change the prefix... No, I don't know why yet.

### Install iconv with macports

  $ sudo port install iconv

### Install MySQL with macports

  $ sudo port install mysql5 mysql5-server

Set some symbolic links:

  $ cd /opt/local
  $ sudo ln -s mysql5/mysql include/mysql
  $ sudo ln -s mysql5/mysql/libmysqlclient.15.dylib lib/libmysqlclient.dylib

### Patch and configure php

If you're on OS X, apply php.patch to the downloaded php.  Then configure
php with the proper flags.  These paths are for OS X, but you should be able
to adjust them for linux:

  $ patch -p0 < ../path/to/php.patch

  $ ./configure --enable-debug \
      --enable-embed \
      --disable-cli  \
      --with-mysql=/opt/local \
      --with-mysqli=/opt/local/lib/mysql5/bin/mysql_config \
      --with-mysql-sock=/opt/local/var/run/mysql5/mysqld.sock \
      --prefix=/usr/local

  $ make && sudo make install

Then, either install the gem, or rake test

## INSTALL:

* No.

-- 
Aaron Patterson
http://tenderlovemaking.com/

--mYCpIKhGyMATD0i+
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)

iQEcBAEBAgAGBQJLtMdeAAoJEJUxcLy0/6/GOsQH/jySDaA9lzE4Xd/K5G8RRQyI
Zn7jBmXorWVEZ4bRM8NufZicjHLEwhC9BEAHAO/UZeIerrP4twt4GM3y3v+Yc+3X
DTY1uOTEHngkIZyx0xayRskogEJDp1OaMgCDXVv2L54QopHO3hXar95gQEQs09Up
NA8u5jafzI+MpjmD2nx7RzI2hAfZuib3MmYCznz3gibk5vLD1OL32zVXsqWVhlh7
cRDwL97NXdP/6iws6rtZwna8MAbGYQLuPw8bpymTIxxOAid/3hx6n+4cZpPj7O08
q1kUTR59ylyT0N7G1fdMruhk8TFf0stBvWqt1FZnne1tmmhRB2BJ6Midhjd3Pqoh
-----END PGP SIGNATURE-----

--mYCpIKhGyMATD0i+--