What version of ruby-oci8 do you use?
What type of ruby-oci8 package do you use?
Could you list *all* files whose name starts with oci8 under C:\Ruby?

On Tue, Mar 30, 2010 at 10:02 PM, Will Raffaele <wgr6 / hotmail.com> wrote:
> irb(main):002:0> require 'oci8'
> LoadError: no such file to load -- oci8lib_18
>  ú⺳> `gem_original_require'
>  ú⺳> `require'
>  ú鸮⺲
You wrote 'gem install ruby-oci8 -v 1.0.4' but
C:/Ruby/lib/ruby/site_ruby/1.8/oci8.rb is
a part of ruby-oci8 2.0 because it requires oci8lib_18.
I guess that you mix some ruby-oci8 versions and package types.