> Change received, merged and tested.
> 
> I've pushed a new beta release (beta3). This closes GH-3 report about
> the incorrect behavior under autospec.
> 
> Can you guys install the new prerelease and let me know? That way we
> can make it official 1.3.0 and I can move to the other projects with
> pending releases ;-)


Interesting.
For some reason on my box, if I run "autospec", it runs this command:


E:\installs\ruby191p376\bin\ruby 
E:/installs/ruby191p376/lib/ruby/gems/1.9.1/gems/rspec-1.3.0/bin/spec 
--autospec E:/dev/ruby/old/spork/test_rails/spec/models/abc_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/views/abcs/edit.html.erb_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/views/abcs/index.html.erb_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/views/abcs/new.html.erb_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/views/abcs/show.html.erb_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/controllers/abcs_controller_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/helpers/abcs_helper_spec.rb 
E:/dev/ruby/old/spork/test_rails/spec/routing/abcs_routing_spec.rb -O 
spec/spec.opts

which outputs, for colors:

in prefork local.rb
E:/installs/ruby191p376/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning: 
Gem::Dependency#version_requirements is deprecated and will be removed 
on or after August 2010.  Use #requirement
???[32m.???[0m???[32m.???[0m???[31mF???[0m???[31mF???[0m???[31mF???[0m???[31mF???[0m???[31mF???[0m???[32m.???[0m???[31mF???[0m???[31mF???[0m???[32m.???[0m???[32m.???[0m???[32m.???[0m???[32m.???[0m???[31mF???[0m???[31mF???[0m???[32m.???[0m???[32m.???[0m???[31mF???[0m???[31mF???[0m???[32m.???[0m???[32m.???[0m???[32m.???[0m???[32m.???[0m???[31mF???[0m???[31mF???[0m???[31mF???[0m???[31mF???[0m???[31mF???[0m

(like it forgot to require win32console or something, even though 
spec.opts has --color).

Any thoughts there? (spork via drb seems to do the same).
Thx.
-rp


If I run that command by itself, colors look fine.
If
-- 
Posted via http://www.ruby-forum.com/.