(Please Cc me when replying, I don't follow ruby-talk@ closely enough to
notice replies)

On 18/03/10 at 05:43 +0900, Eric Hodel wrote:
> On Mar 16, 2010, at 03:22, Leslie Viljoen wrote:
> > I am trying to install Ruby1.9.1 under Ubuntu 9.10 - with gems. I
> > can "apt-get install ruby1.9.1", but I have often had trouble mixing
> > package managers and installing rubygems using apt-get so I usually
> > download it. I also see warnings on the 'net that installing
> > rubygems using apt-get is not recommended.
> > 
> > Contrary to http://ryanbigg.com/2009/01/ruby-191-rubygems-rails/,
> > rubygems does not come included with ruby1.9.1 on Ubuntu, I suppose
> > because it is packaged separately (perhaps wrongly?)
> > 
> > So what I have tried to do is install gems by running the setup.rb
> > program using ruby1.9.1. This seems to work, and I then get a
> > gem1.9.1 which I can use to install gems. But when I try to require
> > those gems, they seem to be missing:
> > 
> > 
> > $ gem1.9.1 list
> > 
> > *** LOCAL GEMS ***
> > 
> > file-find (0.3.4) sys-admin (1.5.2) $ irb1.9.1 irb(main):001:0>
> > require 'rubygems' => true irb(main):002:0> require 'file/find'
> > LoadError: no such file to load -- file/find
> > 
> > 
> > so... should I be using apt-get?
> 
> Maybe there's a package with all of ruby instead of just the pieces
> that ubuntu thinks constitutes ruby.
> 
> My recommendation is to install all of ruby by hand instead of using
> apt-get.

In the past, we (Debian Ruby maintainers, so de-facto Ubuntu Ruby
maintainers since Ubuntu just imports the Ruby packages from Debian) had
problems with the fact that rubygems was shipped with the Ruby
interpreter itself: some gems required a version of rubygems that was
more recent than the one provided by the interpreter.

So the decision was taken to get rubygems directly from upstream,
independantly of the version shipped in ruby 1.8.X or ruby 1.9.1.Y.

Now, on the fact that ruby is split out into several packages, it is
justified by the fact that some ruby apps don't require all the native
libraries normally built with the interpreter (readline, openssl, etc).
To cut off the number of other packages needed on a minimal system that
would just need a ruby interpreter without, say, readline, some of the
native libraries are packaged separately, in the following packages:
libdbm-ruby1.9.1, libgdbm-ruby1.9.1, libreadline-ruby1.9.1,
libtcltk-ruby1.9.1, libopenssl-ruby1.9.1.

For users who want to install "all of ruby", we also provide two
packages that only depend on all the other packages: ruby-full (for 1.8)
and ruby1.9.1-full (for 1.9.1, obviously).

I hope this clarifies the status of Ruby in Debian and Ubuntu a bit.
Also, it would be great if all the sarcasm and nasty comments on this
list each time someone brings up Ruby and Debian or Ubuntu could be
reduced a bit. I am working on providing Ruby packages in Debian and
Ubuntu as a volunteer, and don't really enjoy all the flames I get on
this list. Constructive criticism is welcomed (preferably as bug
reports), but is very rare here, unfortunately.
-- 
| Lucas Nussbaum
| lucas / lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas / nussbaum.fr             GPG: 1024D/023B3F4F |