Hi,

Thanks for your help. I have downloaded and compiled the development kit 
fastcgi-2.4.0 , and i have seen that it contains the fcgiapp.h source 
that i need to compile ruby-fcgi-0.8.9. The problem is that when i try 
to install (gem install ruby-fcgi-0.8.9 --remote), i get the following 
error:

C:\fcgi\include>gem install ruby-fcgi --remote
Building native extensions.  This could take a while...
ERROR:  Error installing ruby-fcgi:
        ERROR: Failed to build gem native extension.

C:/Ruby19/bin/ruby.exe extconf.rb
checking for fcgiapp.h... no
checking for fastcgi/fcgiapp.h... no

make
make: *** No rule to make target `/usr/include/ruby-1.9.1/ruby.h', 
needed by `fcgi.o'.  Stop.


Gem files will remain installed in 
C:/Ruby19/lib/ruby/gems/1.9.1/gems/ruby-fcgi-0.8.9 for inspection.
Results logged to 
C:/Ruby19/lib/ruby/gems/1.9.1/gems/ruby-fcgi-0.8.9/ext/fcgi/gem_make.out

C:\fcgi\include>gem uninstall ruby-fcgi
ERROR:  While executing gem ... (Gem::InstallError)
    cannot uninstall, check `gem list -d ruby-fcgi`

C:\fcgi\include>gem uninstall ruby-fcgi-0.8.9
ERROR:  While executing gem ... (Gem::InstallError)
    cannot uninstall, check `gem list -d ruby-fcgi-0.8.9`

C:\fcgi\include>

I have set the route to fcgiapp.h in my path environment variables, but 
the rubygems can't find it. Also would be an error in the Makefile, 
because of the "/usr/include/ruby-1.9.1", as my Ruby Directory is 
"c:/Ruby19".

Thanks a lot.

Javier Abaroa.

Brian Candler wrote:
> Javier Abaroa wrote:
>> I need some help with gem fcgi-ruby-0.8.8
> 
> I believe the gem is called 'fcgi': gem install fcgi
> (at least it was when I installed it a couple of days ago :-)
> 
> To install the C native version will require a C compiler and the fcgi 
> development kit version 2.4.0, available from www.fastcgi.com, which 
> you'll also have to compile.
> 
> However I seem to remember that fcgi has a 'pure ruby' implementation 
> too. I don't know how you'd tell 'gem install' not to attempt to build 
> the C version. It may be easier just to install fcgi directly from the 
> source bundle:
> http://rubyforge.org/frs/?group_id=926&release_id=42628

-- 
Posted via http://www.ruby-forum.com/.