On Mar 9, 11:13=A0am, Javier Abaroa <gamh03122... / hotmail.com> wrote:
> Hello
>
> I need some help with gem fcgi-ruby-0.8.8. I have tried to create from
> the source rubygem, but in Windows Xp, always i get a lot of errors and
> the process is aborted.
>
> I have tried also to make a direct install of the gem, but always i get
> an error about the "Ruby Native Extensions". This is a common error that
> i have also obtained when i have tried to install other extensions like
> "Sqlite3" and "Ruby-Postgres".
>
> My question is?. Is there any way to obtain the correct native
> extensions and compile fcgi and other extensions without obtain this
> error?.
>
> My OS is Windows-Xp SP3 and my Web Server Apache 2.2.14. I have
> installed also Mingw and Msys, if it were an alternative way to compile
> the modules i have mentioned.
>
> Thank you.
>

Please provide more information about the ruby version you're using.
More precisely, if you're using downloads from ruby-lang, from old One-
Click Installer or the newer RubyInstaller project.

"ruby -v" output will be helpful.

Also, if you're using 1.8 or 1.9 versions of Ruby, as it is unknown to
me if fcgi-ruby extension is compatible with Ruby 1.9.

As you see, that information is required to actually help you.

Please include also the gem installation output: gem install xxx --
debug -V

--
Luis Lavena