On Mon, 2010-03-01 at 17:56 +0900, Saeed Bhuta wrote:
> Saeed Bhuta wrote:
> > Shashank Tiwari wrote:
> >> Are you installing this on a mac, windows or a linux environment? You 
> >> may
> >> need to make sure your C/C++ compiler is configured on the platform for 
> >> the
> >> native extensions to compile and install.
> >> 
> >> Thanks, Shashank
> 
> I just installed the 'libecpg-dev' package and am now getting the 
> following error when trying to install the pg gem:

I believe the libecpg-dev package would only provide the required
packages for developing embedded sql programs.

Open synaptic, scroll down to the postgresql section, and look at the
available packages.  Make sure you have appropriate server and client
packages installed as well as their associated dev packages.