On Feb 26, 12:28=A0pm, Zoltan Penzeli <siaynoqm... / gmail.com> wrote:
> > Please provide information of the Ruby version you're using ('gem env'
> > will be enough)
>
> > Appears that you're using the VC6 build of ruby (i386-mswin32) which
> > requires you have Visual C 6.0 installed (no longer available)
>
> > Please confirm this, and if so, then I would recommend usage of
> > RubyInstaller[1] packages with the DevKit[2] to get a stable Ruby
> > environment with compiler.
>
> > [1]http://rubyinstaller.org/
> > [2]http://rubyinstaller.org/download.html
>
> Hi!
>
> I can access the same environment Sirisha used.
>
> I also made some "upgrades" there, without success. The output of 'gem
> env':
>
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
> RubyGems Environment:
> =A0 - RUBYGEMS VERSION: 1.3.6
> =A0 - RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i386-mswin32]
> =A0 - INSTALLATION DIRECTORY: d:/Ruby/lib/ruby/gems/1.8
> =A0 - RUBY EXECUTABLE: d:/Ruby/bin/ruby.exe
> =A0 - EXECUTABLE DIRECTORY: d:/Ruby/bin
> =A0 - RUBYGEMS PLATFORMS:
> =A0 =A0 - ruby
> =A0 =A0 - x86-mswin32-60
> =A0 - GEM PATHS:
> =A0 =A0 =A0- d:/Ruby/lib/ruby/gems/1.8
> =A0 =A0 =A0- d:/profiles/v-zpenzeli/.gem/ruby/1.8
> =A0 - GEM CONFIGURATION:
> =A0 =A0 =A0- :update_sources =3D> true
> =A0 =A0 =A0- :verbose =3D> true
> =A0 =A0 =A0- :benchmark =3D> false
> =A0 =A0 =A0- :backtrace =3D> false
> =A0 =A0 =A0- :bulk_threshold =3D> 1000
> =A0 - REMOTE SOURCES:
> =A0 =A0 =A0-http://rubygems.org/
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
>
> The interesting thing is, that rake complains about missing Rakefile...
> and indeed, the Rakefile is not under ../lib but under
> ./libxml-ruby-1.1.3-x86-mswin32-60 - I'm getting clueless... :(
>

Ok, seems that my previous comment wasn't clear

libxml-ruby 1.1.3 gem, compiled binary available for download here:

http://rubygems.org/gems/libxml-ruby/versions/1.1.3-x86-mswin32-60

Clearly defines Rakefile as an extension:

C:\Users\Luis\Desktop>gem spec libxml-ruby-1.1.3-x86-mswin32-60.gem
extensions
---
- ext/mingw/Rakefile

Which means the Rakefile is going to be invoked when installed.

Taking a look inside the gem:

C:\Users\Luis\Desktop>gem unpack libxml-ruby-1.1.3-x86-mswin32-60.gem
Unpacked gem: 'C:/Users/Luis/Desktop/libxml-ruby-1.1.3-x86-mswin32-60'

And looked into ext/mingw/Rakefile, which has this note on top:

# We can't use Ruby's standard build procedures
# on Windows because the Ruby executable is
# built with VC++ while here we want to build
# with MingW.  So just roll our own...

Looking at it seems that the gem is copying files at installation
time.

So the Rakefile failure you're receiving is either from RubyGems not
able to find it or from libxml gem itself.

I cannot comment further because I'm not either author or user of
libxml-ruby library.

Please contact the author or report a bug to their tracking system.

--
Luis Lavena