> I'm new to ruby, I'm trying to clarify some install instructions:
>
> "Don't forget to install ruby-dev to and mkmf gem."
>
> are these gems, I can't seem to find anything about them.

Hi,

Those are packages you should install if your copy of ruby is from a
package manager (like apt in Ubuntu/Debian, yum in Fedora, etc).  If
you are running on Windows or building from source I don't think you
have to worry about those.

-Jonathan Nielsen