> /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb

Maybe it's using an "old version" of some of the libraries or what not?
If I were you I would reinstall ruby to some "special" location (like 
$HOME/installs), then install rubygems into that instance and use it 
from there.
HTH.
-r
-- 
Posted via http://www.ruby-forum.com/.