hi all.

I'm in linux and need to make an executable version of a script for one
of my windows-using colleagues to run.  I tried with rubyscript2exe
originally and gave up after various problems and reading about
workarounds which looked like a nightmare.

So, i'm giving ocra a go.  But, it's failing with the following error:

>=== Loading script to check dependencies
>=== WARNING: I18n::Backend::ActiveRecord was not loadable
>[memcache-client] Could not load SystemTimer gem, falling back to Ruby's slower/unsafe timeout library: no such file to load -- system_timer
>/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- Win32API (MissingSourceFile)
>  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
>  from /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
>  from /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
>  from /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
>  from /var/lib/gems/1.8/gems/ocra-1.1.3/bin/ocra:338:in `loaded_dlls'
>  from /var/lib/gems/1.8/gems/ocra-1.1.3/bin/ocra:364:in `detect_dlls'
>  from /var/lib/gems/1.8/gems/ocra-1.1.3/bin/ocra:257:in `build_exe'
>  from /var/lib/gems/1.8/gems/ocra-1.1.3/bin/ocra:461
>  from /var/lib/gems/1.8/bin/ocra:19

I tried installing the win32-api gem but the install failed.  Can this
gem even be installed in linux?

Grateful for any advice, max
-- 
Posted via http://www.ruby-forum.com/.