On Jan 27, 3:27  豮
> os:win xp
> ruby: ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-mingw32]
>
> I got this error:
> Updating RubyGems
> ERROR:  𺯯   
> ERROR:  
> Errno::ENOTCONN: A request to send or receive data was disallowed
> because th
> e socket is not connected and (when sending on a datagram socket using a
> sendto
> call) no address was supplied. (http://gems.rubyforge.org/yaml)
>
> can anyone have a sulotion?

Please check your browser setting for a proxy, use --http-proxy with
gem install command or set HTTP_PROXY variable with a valid URL of the
proxy.

If that is not the issue, try including the following information in
your report:

"gem env" output
"gem install gemname --debug -V" complete output.

--
Luis Lavena