hey all

I just installed the rubyscript2exe gem, and tried to use it on a ruby
script i just wrote called make_xml.rb.  But, i get this error:

/usr/lib/ruby/1.8/rubygems/specification.rb:1038: uninitialized constant
Gem::RubyGemsVersion (NameError)
Couldn't execute this command (rc=256):

I think it may be connected to the first line of my script which starts

require 'rubygems'
require 'hpricot'
require 'fastercsv'
require 'fileutils'

I had to require 'rubygems' in order to be able to require 'hpricot',
which struck me as odd at the time.  Maybe the two problems are symptoms
of the same underlying problem?

here's the versions of the relevant gems i have, in case that sheds any
light.

gem list | grep ruby

rubygems-update (1.3.5)
rubyscript2exe (0.5.3)

grateful for any advice, Max
-- 
Posted via http://www.ruby-forum.com/.