Phillip Gawlowski wrote:
> On 27.12.2009 05:12, Rajinder Yadav wrote:
>> I removed my older ruby package from my ubuntu, built ruby from source
>> successfully. added the sym link from ruby1.8 -> ruby in /usr/bin/
>>
>> however from the IRB I'm getting errors it can't find my gems? how do I
>> fix this, I assume I need to define some environment variables?
> 
> http://docs.rubygems.org/read/chapter/3
> 
> You need to install RubyGems.
> 
> -- 
> Phillip Gawlowski
> 
> 

I already had gems installed? are you telling me I got to repeat the 
entire process to install gem and then all the gem packages?

yadav@KubuntuX64:$ gem list

*** LOCAL GEMS ***

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
cgi_multipart_eof_fix (2.5.0)
curb (0.6.0.0)
daemons (1.0.10)
fastthread (1.0.7)
gem_plugin (0.2.3)
grackle (0.1.7)
haml (2.2.15)
haml-edge (2.3.100)
hpricot (0.8.2)
json (1.2.0)
mechanize (0.9.3)
mime-types (1.16)
mongrel (1.1.5)
nokogiri (1.4.1)
oauth (0.3.6)
patron (0.4.4)
rack (1.0.1)
rails (2.3.5)
rake (0.8.7)
ruby-hmac (0.3.2)
sqlite3-ruby (1.2.5)


-- 
Kind Regards,
Rajinder Yadav

http://DevMentor.org

Do Good! - Share Freely