Got it working. I was using Ubuntu and I had version 1.8 installed 
already. I was installing the gems in ruby1.8 and using ruby1.9
-- 
Posted via http://www.ruby-forum.com/.