From: Luis Lavena <luislavena / gmail.com>
Subject: Re: Ruby 1.8.7 + Tk8.5 with Windows-RubyInstaller
Date: Sat, 19 Dec 2009 08:35:06 +0900
Message-ID: <8109eabf-db61-4f30-add6-ae5582cc0857 / d10g2000yqh.googlegroups.com>
> Right now there is no recipe for 1.8.7, TK 8.5 is only compatible with
> 1.8.7 (changes for it never backported to 1.8.6)

Tcl/Tk8.5.x and 8.6b1 will work with Ruby 1.8.6, when Ruby's tcltklib
is compiled with the version of Tcl/Tk libraries.
Of course, there are no methods for the new features of new Tcl/Tk.
But Tk.tk_call() method can call such new features.

You can try to use latest Ruby/Tk on your released version of Ruby.
Please replace all files under "ext/tk" directory on your Ruby source
to the files of the latest version on Ruby's SVN, and compile it.
I think it may work with 1.8.6 and later.

If you can read Japanese text, please see 
http://www.dumbo.ai.kyutech.ac.jp/~nagai/RubyTk/
-- 
Hidetoshi NAGAI (nagai / ai.kyutech.ac.jp)