On Dec 18, 6:47=A0pm, Roger Pack <rogerpack2... / gmail.com> wrote:
> > =A0http://github.com/oldmoe/mysqlplus/issues/#issue/2
>
> Anybody have any ideas for this situation.
>
> The goal is that you can have installed a mysqlplus gem and a mysql gem.
>
> Both contain ext/mysql.so
>
> If you were to
> require 'mysqlplus'
> then
> require 'mysql'
>
> it would not load the "other gem's version of mysql.so" [currently it's
> random as to which one gets loaded]?
>
> Any thoughts/clues?

require 'mysql' is going to search over installed gems ordered by the
OS and load the specified file.

mysql gem no longer uses the extension as entry point, is mysql.rb

I would recommend usage of gem "mysqlplus" before the require to make
it work

Or do something else prior calling the require 'mysql'

--
Luis Lavena