On Nov 21, 9:57    
> On Nov 21, 2:49  㮮 
>
> > I found the problem!
>
> > activerecord 2.3.4 doesn't work with mysql 5.1.
>
> > Reverting back to the mysql 5.0 did the trick!
>
> > Thanks for trying to help nevertheless, Thufir!
>
> > -Rob
> > --
> > Posted viahttp://www.ruby-forum.com/.
>
> Oh, odd.      > and 5.1 which would effect AR, but I guess there is a bug of some
> kind.         
>

The original user having problems with MySQL was running on Windows.

The MySQL/Ruby binary bindings were built against 5.0.x of MySQL, thus
is going to fail when executed against 5.1.x version of MySQL.

This has been documented in the release notes of the gem:

http://rubyforge.org/frs/shownotes.php?group_id=1598&release_id=38245

And also several times in this mailing list.

--
Luis Lavena