> 1.8.4, but not programs written for 1.8.7 not working for 1.9.1.   
> Whatever happened to backwards compatibility?

You want the most current of the stable branch, not something off of  
what is essentially the development branch.  1.9.1. is a major  
refactoring, a work in progress towards the eventual 2.x versions.