Ryan Davis wrote:
> On Sep 29, 2009, at 18:20 , Michael W. Ryder wrote:
> 
>> Ryan Davis wrote:
>>> On Sep 29, 2009, at 12:00 , Michael W. Ryder wrote:
>>>> The first time it installed a bunch of dependencies.  I just ran  
>>>> it  again and after saying that it was installing RDoc files for  
>>>> nitpick  the following message appeared:
>>>> lib/nitpick/sexp_extension.rb:3:23: ':' not followed by  
>>>> identified  or operator
>>>> Trying to just use nitpick --help results in a bunch of error   
>>>> messages.  Could this be related to the version of Ruby (1.8.4)  
>>>> or  that I am running this on Windows XP Pro?
>>> 1.8.4?!?
>>> yes. you should update.
>>>
>> I updated to 1.9.1 and now it is complaining that ParseTree does not  
>> work with 1.9.1.  Now what do I do?
> 
> ParseTree only works up to 1.8.7. ruby_parser will work for 1.9.x, but  
> it doesn't work for getting ASTs for procs or other live objects.
> 
> 
> 
So my options are:
   1.  Downgrade to 1.8.7
   2.  Somehow patch ParseTree to work with 1.9 which seems to be a 
   f		      feature request for over a year now.
   3.  Patch nitpick to work with ruby_parser
   4.  Forget about using any kind of lint program with Ruby.
Personally I do not like any of the above.  I can understand programs 
written for version 1.8.7 not working with 1.8.4, but not programs 
written for 1.8.7 not working for 1.9.1.  Whatever happened to backwards 
compatibility?