1) require 'activerecord' ... Why do you have this underscore in there?
2) Try :adapter => db[:adapter] instead ?
-- 
Posted via http://www.ruby-forum.com/.