On Sep 29, 2009, at 9:38 AM, Thufir wrote:

> I seem to be missing a gem, yet, according to gem list, I seem to have
> sufficient gems.  It's a bit puzzling in that this script was  
> running and
> now just throws this error.
>
> thufir@ARRAKIS:~/projects/rss$ nl 5.rb
>     1	require 'rubygems'
>     2	require 'active_record'
>     3	require 'feed_tools'
>     4	require 'yaml'
>
>     5	db = YAML.load_file("database.yml")
>     6	ActiveRecord::Base.establish_connection(
>     7	:adapter  => db["adapter"],
>     8	:host   => db["host"],
>     9	:username => db["username"],
>    10	:password => db["password"],
>    11	:database => db["database"])
Did you intend something like this (just a guess)

:adapter => db["mysql"]

Cheers--

Charles
--
Charles Johnson
Advanced Computing Center for Research and Education
Vanderbilt University