I am stuck in a vicious cycle in which I need a newer version of Gems in
order to upgrade my current version of Gems.  Is there a way out of this
aside from a clean install of gems?

I would like to install the newgem package, but I can't because my
version of Gems is too old:

$ sudo gem install newgem
Bulk updating Gem source index for: http://gems.rubyforge.org/
ERROR:  Error installing newgem:
  hoe requires RubyGems version >= 1.3.1


I have Ruby Gems version 1.1.1 installed.  Following the instructions in
Chapter 3 of the Gems manual (http://rubygems.org/read/chapter/3), I try
this to upgrade my copy of Gems:

$ sudo gem update --system
Updating RubyGems
Bulk updating Gem source index for: http://gems.rubyforge.org/
Nothing to update

Then, still following the instructions, I do:

$ sudo gem install rubygems-update
Bulk updating Gem source index for: http://gems.rubyforge.org/
Bulk updating Gem source index for: http://gems.rubyforge.org/
ERROR:  Error installing rubygems-update:
  hoe requires RubyGems version >= 1.3.1

This is the same error message I saw at the beginning so I'm stuck.

Here is my Gems setup:

$ gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 1.1.1
  - RUBY VERSION: 1.8.6 (2008-08-11 patchlevel 287) [i686-darwin]
  - INSTALLATION DIRECTORY: /sw/var/lib/gems/1.8
  - RUBY EXECUTABLE: /sw/bin/ruby1.8
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-darwin
  - GEM PATHS:
     - /sw/var/lib/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://gems.rubyforge.org


I am running OS X.  I installed Gems via the fink package manager for OS
X.

An attempt to install rubygems-update with debug tracing turned on is in
the attached file.

Thanks.

Attachments:
http://www.ruby-forum.com/attachment/4054/gems-update-debug.txt

-- 
Posted via http://www.ruby-forum.com/.