yes, i also get this error

minimum example

gem('twitter4r', '>=0.2.0')

gives me

/usr/local/lib/ruby/1.9.1/rubygems.rb:1093: [BUG] Segmentation fault
ruby 1.9.2dev (2009-09-03 trunk 24741) [i686-linux]

-- control frame ----------
c:0010 p:---- s:0036 b:0036 l:000035 d:000035 CFUNC  :require
c:0009 p:0209 s:0032 b:0032 l:000031 d:000031 TOP
/usr/local/lib/ruby/1.9.1/rubygems.rb:1093
c:0008 p:---- s:0029 b:0029 l:000028 d:000028 FINISH
c:0007 p:---- s:0027 b:0027 l:000026 d:000026 CFUNC  :require
c:0006 p:0092 s:0023 b:0023 l:000022 d:000022 METHOD
<internal:gem_prelude>:159
c:0005 p:0314 s:0020 b:0020 l:000019 d:000019 METHOD
<internal:gem_prelude>:213
Segmentation fault