On Sep 3, 2009, at 12:00, Matt Neuburg wrote:
> As usual after any kind of dramatic change on my computer, ri is
> semi-busted after upgrading to Snow Leopard.
>
> Possibly relevant:
>
> $ ri --version
> ri v1.0.1 - 20041108
>
> (Seems oddly kind of old.)
>
> Anyhow. Works fine like this:
>
> $ ri --system String
>
> [gorgeous display of results omitted here for brevity]
>
> But:
>
> $ ri String
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 
> 1.8/
> yaml.rb:133:in `transfer': invalid subclass (TypeError)

Likely you had RDoc 2 installed then it got replaced by RDoc 1 when  
you upgraded.

Try re-installing RDoc 2.  RDoc 1 can't read it's ri data format.