Adam Wilson wrote:
> OK Now I see where the problem came from.. I managed to update RubyGems 
> again, and now I am back to where I started: gem env shows all ruby 
> paths at /usr/local/bin .. and my $PATH still has /usr/bin as the first 
> part. This is confusing me now! Is there a way of running the RubyGems 
> update specifying the path??
> 
> Thanks for any help.
> Adam.

I also just tried running mongrel_rails ... and I now get this error:

/usr/lib/ruby/1.8/thread.rb:5:in `require': no such file to load -- 
thread.so (LoadError)

Any help to get me out of this mess much appreciated!

(I think it all started when I was haphazardly trying to upgrade my ruby 
in order to run the latest version of Typo for a client, who ended up 
not wanted to use it anyway...)
-- 
Posted via http://www.ruby-forum.com/.