Mark Moseley wrote:
> "gem install ruby-debug-ide" now works for both Ruby 1.8 and 1.9
> (version 0.4.7).
>   
Confused, I am. What is the difference between ruby-debug (which won't 
install with my ruby1.9 installation) and ruby-debug-ide (which also 
won't install)..?

Relative to the ruby-debug-ide install failure, here's what I get:

$ sudo gem19 install ruby-debug-ide
Building native extensions.  This could take a while...
ERROR:  Error installing ruby-debug-ide:
        ERROR: Failed to build gem native extension.

/usr/local/bin/ruby19 extconf.rb install ruby-debug-ide
Building native extensions.  This could take a while...
Building native extensions.  This could take a while...


Gem files will remain installed in 
/usr/local/lib/ruby19/gems/1.9.1/gems/ruby-debug-ide-0.4.7 for inspection.
Results logged to 
/usr/local/lib/ruby19/gems/1.9.1/gems/ruby-debug-ide-0.4.7/ext/gem_make.out
tomc@tomc-desktop:~/Ruby-work/setnet/bin$

That gem_make.out file contains...
/usr/local/bin/ruby19 extconf.rb install ruby-debug-ide
Building native extensions.  This could take a while...
Building native extensions.  This could take a while...

Any help in making sense of this would be much appreciated.

t.

-- 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< tc / tomcloyd.com >> (email)
<< TomCloyd.com >> (website) 
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~