require "zlib"

def inflate(string)
  zstream = Zlib::Inflate.new
  buf = zstream.inflate(string)
  zstream.finish
  zstream.close
  buf
end

Work fine with ruby 1.8, and do not work in ruby 1.9
#<Zlib::BufError: buffer error>
what is wrong ?

Oleg.
-- 
Posted via http://www.ruby-forum.com/.