On Mon, 17 Aug 2009 04:00:10 +0900, oren wrote:

> Thanks Daniel,
> I ended up using this guide:
> http://blog.michaelgreenly.com/2009/04/multiple-versions-of-ruby-on-
ubuntu-3.html
> 
> and i can switch ruby versions with select_ruby script that updates a
> symbolic link that points to the active version.

If you value a working ubuntu system in which you can install such 
packages as vim-gnome and other useful programs that use ruby, by using 
apt-get, then you'll stay *far* away from these instructions, and you'll 
content yourself to useing suffixes on the names of the ruby binaries to 
specify which version you want at the moment you want it.

This is your warning that following these directions will break your 
Ubuntu box in certain respects.

--Ken

-- 
Chanoch (Ken) Bloom. PhD candidate. Linguistic Cognition Laboratory.
Department of Computer Science. Illinois Institute of Technology.
http://www.iit.edu/~kbloom1/