On Aug 19, 10:26=A0am, Peter Bailey <pbai... / bna.com> wrote:
> Roger Pack wrote:
> >> Does anyone know when they're be a one-click installer for Ruby 1.9? I
> >> really don't trust the .zip file that's on the Ruby site now. There's =
no
> >> real install script for it. I'm too dumb to do any kind of "manual"
> >> install, I guess.
>
> > Check outhttp://rubyinstaller.org/
> > "technology preview"
> > looks like the hard working OCI guys have almost got it all up there.
> > -r
>
> I tried this Ruby, and, I have to say, it leaves something to be
> desired. It doesn't do a complete install, meaning, it doesn't put Ruby
> in the path and it doesn't do an association of .rb with Ruby. Also, I
> just can't get Ruby 1.9 to work properly with all of my gems and stuff,
> so, I've just gone back to 1.8.

Sorry for not fulfilling your expectations and our hard work is not up
to your "desired" standards.

To answer your _issues_:

* Adding Ruby to the PATH requires administrative privileges. The
installer doesn't ask for them to be safely installed into corporate
environments.

* It doesn't associate .rb or .rbw files because changes in the
registry related to file associations ALSO require administrative
privileges

* Ruby 1.9 is not meant to be compatible with Ruby 1.8, that is a
fact, and everybody knows about it.

Please refer to the FAQ for other questions that you may have:

http://wiki.github.com/oneclick/rubyinstaller/faq

If you want something different, please, be my guest and fork the
project, patches are always welcome.

--
Luis Lavena