Hi,

I'm trying to run ocra but I seem to have a problem with win32-api. I'm
running this on cygwin and have also tried in an Ubuntu server. Running
ocra outputs an error that tells me to install win32-api, which I do,
but after that I still get the same error.

I've also tried running ocra with --no-autodll option but then the
resulting exe file won't run.

I don't know what I'm missing. I hope somebody can help. Thanks a lot!

Cheers, Manuel

manuel@songoku ~/Mis documentos/Tasks/20090807___STBAR___API-BSH
$ ruby helloworld.rb
Hello World

manuel@songoku ~/Mis documentos/Tasks/20090807___STBAR___API-BSH
$ ocra helloworld.rb
=== Loading script to check dependencies
Hello World
=== ERROR: Failed to load the win32-api gem. Install win32-api or use
--no-autod
ll.
=== CAUSE: LoadError: Permission denied -
/usr/lib/ruby/gems/1.8/gems/win32-api-
1.4.3-x86-mswin32-60/lib/win32/api.so

manuel@songoku ~/Mis documentos/Tasks/20090807___STBAR___API-BSH
$ gem install win32-api
Successfully installed win32-api-1.4.3-x86-mswin32-60
1 gem installed
Installing ri documentation for win32-api-1.4.3-x86-mswin32-60...
Installing RDoc documentation for win32-api-1.4.3-x86-mswin32-60...

manuel@songoku ~/Mis documentos/Tasks/20090807___STBAR___API-BSH
$ ocra helloworld.rb
=== Loading script to check dependencies
Hello World
=== ERROR: Failed to load the win32-api gem. Install win32-api or use
--no-autod
ll.
=== CAUSE: LoadError: Permission denied -
/usr/lib/ruby/gems/1.8/gems/win32-api-
1.4.3-x86-mswin32-60/lib/win32/api.so

PS: Is this the right way to send my commands? Or should I send an
attached text file?
-- 
Posted via http://www.ruby-forum.com/.