On Aug 3, 10:06=A0pm, Calvin Nguyen <calvin98... / yahoo.com> wrote:
> Hi, I am looking for some guidance on the correct and/or most
> streamlined way to upgrade Ruby. Presently I am on Ruby version 1.8.6
> patch level 111. =A0I am looking to upgrade to version 1.8.6 patch level
> 287. =A0When I tried downloading the ruby-1.8.6-p287-i386-mswin32.zip fil=
e
> I unzipped it and was optmistically hoping that i could take all of its
> files and overlay my current installation. =A0When I checked the rails
> version with (rails -v), I get the following error:
> [...]

Please read the note added to Ruby-lang website:

http://www.ruby-lang.org/en/downloads

"Please note that some of the above binaries will require manual
download and installation of additional components detailed on this
page. Please ensure you=92ve followed/performed these steps prior
reporting a bug.

The One-Click Installer does not require these additional tasks."

The page it mention is this:

http://www.garbagecollect.jp/ruby/mswin32/en/documents/install.html

You can also, of course, play out with upcoming One-Click Installer:

http://blog.mmediasys.com/2009/07/06/getting-started-with-rails-and-sqlite3=
/

And read more about it here:

http://wiki.github.com/oneclick/rubyinstaller/

HTH,
--
Luis Lavena