On 30 Jul., 11:21, Marvin G=FClker <sutn... / gmx.net> wrote:
> Marvin G=FClker wrote:
> > Are you using the mswin32 version of WxRuby? I run into problems
>
> Sorry, I meant Ruby, not WxRuby. :-)
>
> Marvin
> --
> Posted viahttp://www.ruby-forum.com/.

Hello Marvin,

thanks for the reply. I had already looked up your posting on the
forum regarding this issue:

> BTW, WxRuby doesn't work with another version of Ruby 1.9 yet as with
> 1.9.1-p0. This is due to a change in the C API of Ruby. I was promised
> that this will be fixed in the next release (seehttp://www.ruby-forum.com=
/topic/187872#new), but I don't know when this
> will be (and since I'm using Linux Ubuntu most I won't recognize a new
> Windows release quickly).

So I did a fresh install of Ruby, using "mingw32-ruby-1.9.1-
wxruby-2.0.0-setup.exe" from rubyforge. That's a Ruby installation
with pre-installed wxRuby gems. Bigdemo.rb ran without any problems.
So I am going to reinstall and update my gems and everything should be
fine (hopefully).

> What's the version of RubyGems you are using?

On the brand new Ruby installation (see above) I ran

 gem -v

and found out that I was still using 1.3.1. So I typed:

 gem update --system

This was the result:

---begin---
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.5
:0:Warning: Gem::SourceIndex#search support for String patterns is
deprecated
Updating RubyGems to 1.3.5
Installing RubyGems 1.3.5
c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/
config_file.
rb:39:in `new': wrong number of arguments (5 for 4) (ArgumentError)
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/config_file.rb:39:in `<class:ConfigFile>'
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/config_file.rb:12:in `<top (required)>'
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/gem_runner.rb:8:in `require'
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/gem_runner.rb:8:in `<top (required)>'
        from setup.rb:25:in `require'
        from setup.rb:25:in `<main>'
RubyGems system software updated
--end--

Now, when I type

  gem -v

I get this:

---begin---
c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/lib/rubygems/
config_file.
rb:39:in `new': wrong number of arguments (5 for 4) (ArgumentError)
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/config_file.rb:39:in `<class:ConfigFile>'
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/config_file.rb:12:in `<top (required)>'
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/gem_runner.rb:8:in `require'
        from c:/ruby/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.5/
lib/rubygems
/gem_runner.rb:8:in `<top (required)>'
        from c:/ruby/bin/gem.bat:17:in `require'
        from c:/ruby/bin/gem.bat:17:in `<main>'
---end---

Does this mean I have broken rubygems on mingw32 by typing "gem update
--system"? Typing

  "gem search wxruby-ruby19 --remote"

or trying to install a gem - any gem - gives me the same argument
error.

Now I'm even more confused. "Bigdemo" is still working after the
failed rubygems upgrade, but now I'm unable to install any gems. Of
course, I can reinstall and stay with rubygems 1.3.1, but is this an
issue that should be reported to someone?

Kind regards,

Rainer