On Jul 28, 2009, at 16:25, Reid Thompson wrote:
> Ryan Davis wrote:
>> On Jul 28, 2009, at 08:40 , Reid Thompson wrote:
>>> How can i work around this error?  Is it possible to force ruport  
>>> to use
>>> 1.5.0?
>>>
>>> can't activate fastercsv (= 1.2.3, runtime) for ["ruport-1.6.1"],  
>>> already activated fastercsv-1.5.0 for [] (Gem::LoadError)
>> that latter "for []" doesn't help, or it is (poorly) stating that  
>> YOU activated fastercsv. I'm gonna guess the latter. So, either  
>> activate it with a version specifier that matches:
>>  gem 'fastercsv', '= 1.2.3'
>> or activate ruport before you require fastercsv.
>> We really need to stop using '= x.y.z' because of problems like  
>> this. In this case tho, it looks like ruport is falling behind on  
>> maintenance (or you're using an old version, which is another way  
>> for you to fix this if so)
> Thanks for your response.
>
> This was ruport installed today via gem - so should be the latest  
> version.
> How do I activate ruport before requiring fastercsv, is it simply  
> requiring ruport before fastercsv, or is there more involved?

require 'ruport' before require 'fastercsv' should be sufficient.

> I would hope that ruport would work with fastercsv >=1.2.3 w/o issue  
> and that there would be a simple way to make it do so???


$ gem dep -r ruport
Gem ruport-1.6.1
   fastercsv (= 1.2.3, runtime)
   pdf-writer (= 1.1.8, runtime)

[...]
$ gem list -r fastercsv

*** REMOTE GEMS ***

fastercsv (1.5.0)

Looks like it's locked down, it should probably be '~> 1.2' or similar  
instead. Greg?