Hey Ruby-talk,
I was wondering, is there a way I can access older versions of the
Ruby core documentation? I'm trying to debug an issue with
Kernel.select on Ruby 1.8.1 (that works fine with 1.8.6 and 1.9.1),
and I want to see if the behavior was documented to be the same as the
1.8.6 and 1.9.1 version of it.

Unfortunately, the machine I'm on also doesn't have any of the Ri docs
installed, so I can't see them that way. I also tried doing a ' grep
-R "select(" * ' in the Ruby lib directory, but didn't see the
implementation in there. It also doesn't look like ruby-doc.org has
the earlier versions either.

One other question, Is there a bugtracker for versions of Ruby earlier
than 1.8.6? Redmine.ruby-lang.org seems to be fairly recent and
doesn't look to have issues older than 2008, I wanted to look and see
if maybe I was hitting a bug that was fixed in a later version of
Ruby.

- Lee