I am a newbie to Ruby environment. I am trying to write a simple GUI
application to our website, using Shoes and Watir. But when I specify
watir in the Shoes.set up, as follows:

Shoes.setup do
  gem 'hpricot >= 0.8.1'
  gem 'windows-pr'
  gem 'watir >= 1.6.2'
end

I get the following error:

Installing Watir
Looking for watir
Error in C:/Program Files/Common
Files/Shoes/0.r1134/ruby/lib/rubygems/installer.rb line 187 |

hoe requires RubyGems version >= 1.3.1

I have installed ruby 1.8.6 (under C:\Ruby...) and other needed gems,
but Shoes is reading/installing Ruby and Gems from its own location
(C:/Program Files/Common Files/Shoes/0.r1134/ruby/)

1. How can I find out what version RubyGems is installed under Shoes?
2. How can I update RubyGems version under Shoes?


Thanks
Ravi
-- 
Posted via http://www.ruby-forum.com/.