Here's my environment followed by what I'm seeing.  I dug into the
code and found out that the "bad URI" it's complaining about is nil,
which is indeed pretty bad for a URI.  I've searched for an answer in
vain.  I've reinstalled rubygems by running setup.rb from the latest
rubygems release.

Does anyone have any ideas?


[dougmcbride@shiny /d/rubygems-1.3.4] sudo gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.4
  - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [universal-
darwin9.0]
  - INSTALLATION DIRECTORY: /Library/Ruby/Gems/1.8
  - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-9
  - GEM PATHS:
     - /Library/Ruby/Gems/1.8
     - /Users/dougmcbride/.gem/ruby/1.8
     - /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/gems/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources => ["http://gems.rubyforge.org/"]
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/


[dougmcbride@shiny /d/rubygems-1.3.4] sudo gem --debug install ruby-
debug
Exception `NameError' at /Library/Ruby/Site/1.8/rubygems/
command_manager.rb:161 - uninitialized constant
Gem::Commands::InstallCommand
Exception `Gem::LoadError' at /Library/Ruby/Site/1.8/rubygems.rb:826 -
Could not find RubyGem test-unit (>= 0)

Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:120 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:120 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:120 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:120 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:120 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:120 - end of file
reached
Exception `EOFError' at /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:133 - end of file
reached
nil
Exception `URI::InvalidURIError' at /System/Library/Frameworks/
Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/uri/common.rb:437 - bad
URI(is not URI?):
ERROR:  While executing gem ... (URI::InvalidURIError)
    bad URI(is not URI?):
	/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
1.8/uri/common.rb:437:in `split'
	/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
1.8/uri/common.rb:486:in `parse'
	/Library/Ruby/Site/1.8/rubygems/remote_fetcher.rb:258:in
`open_uri_or_path'
	/Library/Ruby/Site/1.8/rubygems/remote_fetcher.rb:288:in
`open_uri_or_path'
	/Library/Ruby/Site/1.8/rubygems/remote_fetcher.rb:164:in `fetch_path'
	/Library/Ruby/Site/1.8/rubygems/remote_fetcher.rb:108:in `download'
	/Library/Ruby/Site/1.8/rubygems/dependency_installer.rb:232:in
`install'
	/Library/Ruby/Site/1.8/rubygems/dependency_installer.rb:222:in `each'
	/Library/Ruby/Site/1.8/rubygems/dependency_installer.rb:222:in
`install'
	/Library/Ruby/Site/1.8/rubygems/commands/install_command.rb:118:in
`execute'
	/Library/Ruby/Site/1.8/rubygems/commands/install_command.rb:115:in
`each'
	/Library/Ruby/Site/1.8/rubygems/commands/install_command.rb:115:in
`execute'
	/Library/Ruby/Site/1.8/rubygems/command.rb:257:in `invoke'
	/Library/Ruby/Site/1.8/rubygems/command_manager.rb:132:in
`process_args'
	/Library/Ruby/Site/1.8/rubygems/command_manager.rb:102:in `run'
	/Library/Ruby/Site/1.8/rubygems/gem_runner.rb:58:in `run'
	/usr/bin/gem:21