> Do you mind expanding on this?  I tested it with that particular version
> of ruby on windows, so I'm surprised it doesn't work.  As of 1.3.0, we
> support that version, so if it doesn't work, I consider that a bug.
Of course...

gem install nokogiri -> failed

I copied libxml, libxslt*  to ruby installation manually.

c:\gem install nokogiri
Building native extensions.  This could take a while...
ERROR:  Error installing nokogiri:
    ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb
checking for iconv.h in 
/opt/local/include/,/opt/local/include/libxml2,/opt/local/include,c:/ruby/include/libxml2,c:/ruby/include,/usr/local/include/libxml2,/usr/include/libxml2... 
yes
checking for libxml/parser.h in 
/opt/local/include/,/opt/local/include/libxml2,/opt/local/include,c:/ruby/include/libxml2,c:/ruby/include,/usr/local/include/libxml2,/usr/include/libxml2... 
yes
checking for libxslt/xslt.h in 
/opt/local/include/,/opt/local/include/libxml2,/opt/local/include,c:/ruby/include/libxml2,c:/ruby/include,/usr/local/include/libxml2,/usr/include/libxml2... 
yes
checking for libexslt/exslt.h in 
/opt/local/include/,/opt/local/include/libxml2,/opt/local/include,c:/ruby/include/libxml2,c:/ruby/include,/usr/local/include/libxml2,/usr/include/libxml2... 
yes
checking for xmlParseDoc() in -lxml2... no
libxml2 is missing.  try 'port install libxml2' or 'yum install libxml2'
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

gem install nokogiri -s http://tenderlovemaking.com/ -> failed
c:\>gem install nokogiri -s http://tenderlovemaking.com/
ERROR:  Error installing nokogiri:
        nokogiri requires Ruby version ~> 1.8.0

I tried to use rake-compiler on OpenSUSE and Debian with Ruby 1.9.1 (in 
system) and it failed on frex error. I tried to use it again with Ruby 
1.8 (in system). Nokogiri didn't find ruby header files (I installed 
every ruby dev package)

* http://www.zlatkovic.com/pub/libxml/

The result is the nokogiri is impossible to install on Windows with Ruby 
1.9.1. Yeah, I'm not a rocket scientist :(
-- 
Posted via http://www.ruby-forum.com/.