On May 28, 6:22  Į
> I simplified things for me ..
>
> I went back to 1.8.7 (no more errors)
>
> 1.9.1 is just not ready from both a gems usable standpoint and
> especially a windows standpoint.
>

I completely understand your frustration.

Is even more frustrating trying to release Ruby installers for 1.8 and
1.9 when it's own set of test fail, stall or crash.

Not so much confidence in the language itself to be able to support
it :-P

I've been working in better-build branch of mysql-gem at GitHub:

http://github.com/luislavena/mysql-gem/tree/better-build

Just one small point: tried to build with 5.1 and failed, so next push
of changes are going to be for MySQL 5.0.

Sorry not been able to help you more, I have on my plate the following
gems:

rake-compiler with fat-binaries (to bundle 1.8 and 1.9 versions of
extensions).

Once that is done, I can move to:

sqlite3-ruby: mostly done, still tests fails on 1.9:

http://pastie.org/486098

mysql-gem is the next in the queue.

Then back to win32console and pretty colors for RSpec and Cucumber,
adding unicode support for 1.9.

--
Luis Lavena