On Apr 29, 6:23 ¨Βν¬ Ννγομμι°ΝοΌννγίγομμ®®®ΐωαθοο®γονχςοτεΊ
> Lyle Johnson wrote:
> > On Wed, Apr 29, 2009 at 4:10 PM, Mmcolli00 Mom <mmc_coll... / yahoo.com>
> > wrote:
>
> >> I just installed ruby 1.8.6 stable version on windows xp pc. When I try
> >> to install gems by gem install gemname...it says 'command not
> >> recognized'
>
> > Make sure that the "ruby\bin" directory is in your PATH.
>
> I copied those to the bin and then set my path to ruby\bin. Then I use
> gem install gemname but it says my rake is of invalid format...so I go
> to next gem and use gem install and it says that gem is also of invalid
> format.

Will be much more helpful than your description that you can provide
output of:

set PATH
gem env
gem install rake

The actual commands and the real output can help us help you.

--
Luis Lavena