On Thu, Apr 16, 2009 at 8:32 PM, James Gray <james / grayproductions.net> wrote:
ows.
>
> One easy way is just to install 1.9 separate from your 1.8 install.   > do that by feeding the configure script a --program-suffix=19 option which
> would add a 19 to the end of all the executables it installs.  > would use ruby19, irb19, etc.
OMG why did I not ask you, or err, reading ./configure --help a little
bit more carefully, before installing!!!!
This avoids probably the kind of compatibility problems I ran into.
Juan, by all means, follow James' approach if you cannot go with
JRuby.
R.