I'd like to start using Ruby 1.9 more often.  Often I could use the  
extra performance.  However, I'm still concerned about bugs and  
incompatibilities.   Is there a practical way to use 1.9 in such a  
way that these potential problems are minimized?  I mostly use Linux  
and OSX, and on rare occasions Windows.