Hello,
I have a Ruby/Tk code that runs perfectly in 1.8.x but stalls in
1.9.1.

Doing some investigation it seems that even the very basic programs:
require 'tk'

(that's not a mistake... it's literally only the require line) ends up
freezing the program. Anyone has any idea on what could be the
problem?

I am running Mac Os X 10.4 (Tiger), on a G4 machine.

Thank you

Diego