Vetrivel Vetrivel wrote:
> I have dowunloaded the xml-simple-1.0.12.gem .
> 
> I used  xml-simple to requie .
>                require 'xml-simple' But it doesn't work
> 
> Then I have given like this  It works,
>            require 'xmlsimple'
> 
> My question is that,
> 
> How do i know it should be xmlsimple.

In summary, you don't. Read the documentation/examples, or look at what 
files the gem contains and make an educated guess as to the one which 
you should require.
-- 
Posted via http://www.ruby-forum.com/.