unknown wrote:
> I have some code that was written in the Ruby-1.8ish era.  However,
> the newer versions append the version number to all library/etc
> filenames, which is causing problems- for example, "/usr/local/bin/
> ruby" no longer exists, it's "/usr/local/bin/ruby19".

This is a compile-time option: ./configure --program-suffix=19

> I'd stay with
> 1.8 but when I try to run the software on the new system I'm trying to
> set up (FreeBSD) it complains that gzip library isn't present.

If you're trying to run code written under 1.8, then you definitely need 
1.8. There are many differences between 1.8 and 1.9, some minor but many 
substantial.

Hence many people need to have both 1.8 and 1.9 installed 
simultaneously, and the suffix is one way to achieve this.

I'd argue that 1.8.7 is a third incompatible variant, but let's not get 
into that now :-) Suffice to say, if your code was written under 1.8, 
then you should install a recent 1.8.6.

> I know from Googling that zlib was included with Ruby starting with
> 1.8, so I'm not quite sure what's going on there.

It is. How are you installing ruby - from ports? Compiling from source?

If compiling from source it should be easy to debug. If the zlib 
extension isn't being build, you'll find the answer in 
ext/zlib/mkmf.log.

I believe zlib is part of FreeBSD base system, so you'll need to check 
what's happening.

> Was there some drastic change in Ruby that necessitated the versions
> not commingle?  Argh.

Yes :-)
-- 
Posted via http://www.ruby-forum.com/.