> If not, has anybody compiled Ruby for AIX with . . . 
> 
> 	IBM's C compiler?

YES, just yesterday, and I'll save you some trouble:

Ruby 1.6.4 compiles and installs just fine on my AIX 4.3.3 machine, with 
the IBM C compiler. I got the tarball, ran 'configure', 'make, su'ed to 
root, and 'make install'. It all installs into /usr/local/bin 
and /usr/local/lib/ruby. I had no problems.

Ruby 1.6.6 does NOT compile properly. You need to replace 
ext/digest/defs.h with a new one before it will work. I just asked about 
this the other day on this list, and Matz replied with the replacement 
file. If you can't easily find this in the archives, reply directly to me 
(tgphelps / iglou.com), and I'll send it to you.