+1 for the main question,
 but...


On Feb 11, 9:15=A0pm, Charles Oliver Nutter <charles.nut... / sun.com>
wrote:
> I still feel like Ruby 1.9 should have been 2.0.
> Then 1.8.7 could have been 1.9, 1.8.8 could be 1.10,
> and so on, ...

I also agree about this. Perhaps it isn't too late
to rename "1.9.1.0.0.1" to "2.0.0.0.1" ??

Also is it possible to make some "ruby20.rb" package
wich emulate some features of 1.9 present in 1.8.7?

Then in ruby-1.8.8 which would be 1.8.6 like
but would allow us to write:

   require 'ruby20'

Then all sugar features that are present in ruby 1.8.7
would be enable!
Perhaps this package could even be required from a 1.8.6
ruby version??

-- Maurice

P.S.
+1 for the original question ;-)